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1. Preface 

Monitoring of emergency lighting has never been so user-friendly. This was made possible 

thanks to an application compatible with the system for the management of emergency lighting 

DATA 2 and central battery system TM-CB A. ELVIS visualises facilities with emergency lighting 

fittings installed, making building administration much easier. The user can place fittings on the 

building plan to easily detect the location of and precisely diagnose a defective fitting. To increase 

operating comfort even further, the program has the function of automatic and cyclic sending of 

reports on the system status to a given e-mail address. 

2. Installation 

 

 

 

To install the program, run the installer by clicking the ‘ElvisInstaller_en.msi’ file on the 

supplied storage medium. Follow the instructions in the installer and accept the license 

agreement. 

 The user can select modules that will be installed: 

• Elvis main application. 

• Elvis Online – service of sharing the system status through the website. 
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NOTE! The installation process requires .NET Framework 4.6.1. libraries to be installed. In the 

absence of libraries, an error will be displayed and the installation will be interrupted. 
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3. Introduction 

 

The application window can be divided into the following sections: 

• menu bar, 

• list of fittings, 

• background drawing with the location of fittings, 

• navigation bar, 

• list of surface groups, 

• toolbar. 

 

The menu bar allows the following actions: 

 

Menu Sub-menu Action 

File Generate Status Report Generating a report on the system status 

Close Program closing 

Edit Central Stations Management of central stations 

Surface Groups Management of surface groups 

View Surface Group View Switching to surface group view 

Topology View Switching to topology view 

Operations Add Surface Group Adding a new surface group 

Add Central Station Adding a new central station 

Log out of the Central 

Station 

Logging out of all central stations 
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Tools Create Backup Creating and saving the program backup 

Settings Configuration of program settings 

License Manager License management 

 

The toolbar is at the bottom of the window.  

It shows the following states:  

• currently selected central station with information about an active user,  

• enabled filtering of the list of fittings,  

• mode (normal/editing).  

The bar allows to switch the view and change the language. 

 

The first time the user starts the program, they should: 

1) install a license using the License Manager, 

2) add and configure surface groups, 

3) add and configure central stations, 

4) arrange fittings in the background drawings, 

5) configure automatic sending of reports to an e-mail address (optional), 

6) configure automatic creation of program backup (optional). 
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4. License Manager 

ELVIS is fully operational only with an active license file. In the absence of a license, the 

program has only basic functionality and it is not possible to check the status of a central station. 

 

 
 

 

Limitations of program without a license for the central station: 

• edit mode cannot be enabled, 

• fitting, circuit and station status is not refreshed, lack of communication is shown for all 

the objects, 

• fitting, circuit and station details are not available, 

• report cannot be generated, 

• no action of the fitting can be performed, 

• fitting icon can be neither placed nor moved in the background drawings. 

 

License can be added and removed via the License Manager (Tools -> License Manager). The 

Manager window contains a list of loaded license files. Click on a license file on the list to display 

information on the period of validity of the license, as well as central stations and functionality 

operated by the file. 

In order to purchase a new license and if the user wants to renew their license, contact the Sales 

Department of TM Technologie. 
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5. Configuration of Surface Groups 

 

 

Select ‘Operations’ -> ‘Add Surface Group’ from the menu to open a window for adding 

a surface group. 

Proceed as follows to add a surface group: 

• enter a unique name of the surface group, 

• add a new surface by clicking on ‘Add...’, 

• specify the surface name (e.g. 2nd floor), 

• assign a background drawing to the surface by clicking on ‘Load’ and selecting the 

appropriate file. 

The background drawing must be a SVG (Scalable Vector Graphics) file. 

• click ‘Save’ to confirm that the new group has been added. 

In the case of mistake, it is possible to remove the surface by pressing the trash icon. 

 

Once the group is added, it can be edited or removed using ‘Edit’ -> ‘Surface Groups’ on the menu 

bar. 

 

NOTE! It is not advisable to use surfaces with too much details. 
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6. Configuration of Central Stations 

 

 

Select ‘Operations’ -> ‘Add Central Station’ from the menu to open a window for adding 

a new central station. 

Proceed as follows to add a new central station: 

• enter any name identifying the central station and its IP address, 

• set the port to the default value of 9760, 

• test the connection using the ‘Test Connection’ button, 

In the absence of connection, check the IP address of the central station and that the 

connection is not blocked by the system firewall. 

• each central station must be assigned a surface group. 

Click ‘Save’ to display the login window. Enter a login and a password of a user previously 

created for the added central station. 

The central station cannot be added if the login data is incorrect or if there is no 

connection.  

Central stations added to the system are displayed on the list of fittings. 

Once the station is added, it can be edited or removed using ‘Edit’ -> ‘Central Stations’ on the 

menu bar. 
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7. Surface Group View 

After assigning a surface group to the program, a 3D view of the group is created. The user 

can add and configure their own view of surface groups. Switch to another surface group to 

display its preview. If the user defined a custom view, it will be displayed in the program. 

Otherwise, the program will display a default view.  

7.1  Default View 

 
 

This is a preview created automatically after adding a surface group. It shows the 

projections of surfaces placed one below the other. If at least one error of fittings occurs, the 

corresponding surface will be highlighted in red. The user can zoom in/out and rotate the view. 

Click on the surface to go to the corresponding background drawing. 

7.2  Custom View 

This is a building preview created by the user. It shows the projections of surfaces 

according to user settings. If at least one error of fittings occurs, the corresponding surface will 

be highlighted in red. Click on the surface to go to the corresponding background drawing. 

Click on ‘Add Custom View’ to go to the window for adding own view/plan of the building. 

After entering the edit mode for custom view, the following buttons are available in the program: 

• Add Label – adding a text label to the preview, 

• Add Polygon – adding a polygon that maps the surface (confirmed by pressing Enter), 

• Select Image – selecting a background image, 

• Save Changes – saving changes to settings, 
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• Delete View – deleting a custom view and returning to the default view. 

 

 
 

Additionally, the user can select the polygon colour palette, label font size, polygon colour, 

surface assigned to the polygon, as well as text prompts. 

When adding a polygon, select its colour, assigned surface and, optionally, enter a text displayed 

after selecting the polygon. Click ‘Delete’ to delete the polygon. 

When adding a label, enter a text to be displayed and select the font size. Click ‘Delete’ to delete 

the label. 
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8. Topology View 

 
 

The topology view can be enabled by switching the type of view on the menu bar or 

toolbar. 

 

 
 

Once the view is switched, the screen displays a quick view of the system in the form of blocks 

containing information about the connected centrals, distributors, stations, circuits and fittings. 

If an error occurs for a fitting with a given address, its address is displayed in red. Click the block 

with the fitting address to select the corresponding fitting on the list. 

The user can switch between the horizontal and vertical view (icon in the upper right corner). 

Click the printer icon to print the view. 

  



 

DATA 2 – Instruction Manual TM TECHNOLOGIE 15 

9. List of Fittings 
The list of fittings shows fittings added to the system. 

Click on the ‘Expand / Collapse’ button to expand or collapse the list of fittings. 

The ‘Filters’ button is used to enable the option of filtering the list of fittings by preset 

parameters, such as selected errors, central stations, distributors. Click on ‘Clear filters’ to delete 

all filters. 

 

 
 

9.1  DATA 2 system 

The list can be presented in two ways: 

• Topology – central stations constitute the main element of the list. Central stations 

include distributors (C-Bridge) divided into channels (A/B/C/D). Channels include fittings 

sorted by address. 

This is exactly the same as in the control unit for fittings. 

• Groups – central stations constitute the main element of the list. Each central station 

includes three types of groups (test, night, and fire and emergency groups). Groups 

includes fittings assigned to them. 
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Possible list items: 

• Central station – contains information about the system status and communication with 

it. Click this item to display additional information below the list (serial number, assigned 

surface group, central station response time). It is possible to send commands to all 

fittings of the central station. A red symbol indicates an error. 

• Group (test / night / fire and emergency group) – contains fittings assigned to the group. 

It is possible to send commands to all fittings of the selected test group. 

• Distributor (C-Bridge) – contains information about the distributor state, communication 

with a central station, power status, and battery status. Click this item do display the date 

of the last update of the status of fittings connected to the distributor. It is possible to 

send commands to all fittings of the selected distributor. A red symbol indicates an error. 

• Channel (A/B/C/D) – shows fittings connected to the channel of individual distributors. 

It is possible to send commands to all fittings on the channel. A red icon of the channel 

informs that at least one erroneous fitting is present on the channel. 

• Fitting – contains information about the fitting status. It is possible to send commands to 

the fitting after logging in to the program. If the fitting was removed from the central 

station and it is still present on the list of fittings (highlighted in black), it can be deleted by 

right-clicking on it and selecting ‘Delete’. 

 

Each fitting item on the list informs on: 

• general fitting state (  – OK,  – error), 

• physical address of the fitting displayed as, e.g. 01/A/02, meaning that the fitting has the 

address 2, is connected to the C-Bridge distributor 1, to the channel A, 

• communication status (  – OK,  – no communication), 

• power status (  – OK,  – power failure), 

• function test status (  – OK,  – in test mode / postponed,  – error), 

• autonomy test status (  – OK,  – in test mode / postponed,  – error), 

• battery status (  – OK,  – charging,  – error), 

• light source status (  – OK,  – lights,  – error), 

• fitting lock (  – unlocked,  – locked). 
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The user can send the following commands to fittings: 

• enable function test, 

• enable autonomy test, 

• cancel tests in progress or pending tests, 

• lock the fitting, 

• unlock the fitting. 

9.2  TM-CB A system 

The list can be presented in two ways: 

• Topology – central stations constitute the main element of the list. Central stations 

include stations divided into circuits. Circuits include fittings sorted by address. 

 This is exactly the same as in the control unit for fittings. 

• Groups – central stations constitute the main element of the list. Each central station 

includes night groups. Groups includes circuits assigned to them. 

Possible list items: 

• Central station – contains information about the system status and communication with 

it. Click this item to display additional information below the list (serial number, assigned 

surface group, central station response time). A red symbol indicates an error. 

• Group (night) – contains circuits assigned to the group. 

• Station – contains information about the station state. A red symbol indicates an error. 

• Circuit – contains information about the circuit state. A red symbol indicates an error. 
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• Fitting – contains information about the fitting status. If the fitting was removed from the 

central station and it is still present on the list of fittings (highlighted in black), it can be 

deleted by right-clicking on it and selecting ‘Delete’. 

Each station item on the list informs on: 

• station status (  - station ok,  - station error. 

Station error indicates one of the following errors: 

- general error, 

- long test error, 

- circuit error, 

• communication status (  - ok,  - no communication), 

• power supply status (  - basic power supply,  - no basic power supply), 

• test status (  - last test correct,  - station test in progress,  - test error), 

• battery mode (  - normal operation,  - battery mode), 

• charger state (  - no charging,  - charging in progress,  - charger error), 

• deep discharge (  - batteries are in working order,  - batteries after deep 

discharge), 

• service mode (  - station is not in service mode,  - station is in service mode). 

Each circuit item on the list informs on: 

• general circuit state (  - ok,  - disabled or unconfigured,  - error), 

• physical address of the circuit, e.g. 01/12A, which informs that it is the circuit A on the 

controller no. 12 on the substation no. 1), 

• communication status (  - ok,  - error), 

• circuit output voltage (  - no voltage,  - DC,  - AC), 

• card state (  - ok,  - error), 

• default operating mode of the circuit (  - disabled or unconfigured,  - non-

maintained operation,  - maintained operation), 

• circuit test status (  - test ok,  - test in progress,  - test error), 

• result of current measurement in the last test (  - result ok,  - error), 

• circuit off state (  - circuit is disabled,  - circuit is enabled);  

the circuit signals the off state when it is: 
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- unconfigured, 

- disabled, 

- in service mode. 

Fittings designation: 

•  fitting ok, 

•  fitting added and untested, 

•  faulty fitting, 

•  fitting operates according to dipswitch settings on the address module, 

•  fitting configured for maintained operation (the circuit must also operate in 

maintained mode), 

•  fitting configured for non-maintained operation. 

10. Fitting Management 
 

Once the license is installed and surface groups and central stations are configured, the 

fittings must be arranged on the building plans (added surfaces).  

By dragging the fittings from the list and dropping them on the surface, the user enables the 

editing mode and the program will ask them to log in. Enter the username and the password 

which are the same as for the central station account. After dragging the fitting, select its type 

(emergency, evacuation, or dynamic fitting). 

It is also possible to add fitting (after logging in) by right-clicking on the surface and selecting the 

‘Place fitting’ option. In the window, select the central station and enter the address of fitting to 

be added (e.g. ‘1/2a/7’, ‘1b35’ or ‘1/b/35’). The possible separators are slash and backslash, 

period, comma, underscore, minus and colon. 

Fittings added to the surface can be: 

• moved (by dragging the fitting symbol and dropping it in other place), 

• deleted (using the navigation bar), 

• resized (using the navigation bar), 

• activated (after clicking the fitting on the surface it will be selected on the list of fittings) 

– only DATA 2 fitting. 

If the fitting symbol turns red, it means that an error occurred. A yellow glow around the fitting 

(DATA 2) indicates that the fitting is lit. 
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11. Navigation Bar 
 

The navigation bar consists of the following four elements: 

• Navigation – contains a miniature of the selected surface. After appropriate 

magnification, the currently displayed view can be moved in the main window. The slider 

allows to change the zoom in or zoom out value. 

 
• Info – information about the currently selected object. The window displays the object 

address and status. It is possible to read the object details. 

 

 
• Tests – allows to trigger some action for the selected fitting (enabling or cancellation of 

tests, locking or unlocking the fitting). Only DATA 2 fittings. 

 
• Fitting settings – allows to change the type of the fitting, delete or resize the fittings 

displayed on the surface. 
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12. Details 

12.1  Fitting Details 

 

 
 

After logging in, click on ‘Display fitting details’ on the navigation bar to display additional 

information about the selected (DATA 2) fitting: 

• date and duration of the last power failure, 

• date and duration of the last function test, 

• date and duration of the last autonomy test. 

The ‘Refresh’ button is used to update the state of the fitting parameters. More parameters is 

available for TM Technologie’s service personnel. 

12.2  Station Details 

After logging in, click on ‘Show detailed info for station’ on the navigation bar to display 

additional information about the selected station: 

• measurements, 

• settings, 

• errors. 

The ‘Refresh’ button is used to update the state of the station parameters. 
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12.3  Circuit Details 

After logging in, click on ‘Show detailed info for circuit’ on the navigation bar to display 

additional information about the selected circuit: 

• measurements, 

• settings, 

• errors. 

The ‘Refresh’ button is used to update the state of the circuit parameters. 
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13. Generating a Report 
Select ‘File’ -> ‘Generate Status Report’ on the menu bar to display the window for 

generating a report on the system status. The user selects whether the generated report is to 

contain the status of all fittings or only those that contain an error. Click the ‘Generate’ button 

and select the name and location where the report will be saved. The report is generated as 

a PDF file. In the program settings, the user can configure automatic generation and sending of 

reports to a given e-mail address. 

 

14. Program Settings 
The Program Settings window is available after selecting ‘Tools’ -> ‘Settings’ on the menu 

bar. The following three tabs are then available: 

• Reporting – configuration of automatic generation of reports, 

• Synchronization – configuration of the refresh rate of data from central stations. The 

available range of settings is 30-120 seconds. 

• Backup – configuration of automatic generation and recording of program data backup 

(selectable cycle and time of generation). 

 

After changing the settings, click the ‘Apply’ button. Click on ‘Save’ to save changes and exit the 

window. Click on ‘Cancel’ to cancel the changes and exit the window. 

The window contains information about the current software version. 
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14.1  Automatic Generation of Reports 

 

The user can configure automatic generation and sending of reports to a given e-mail address. 

Reports will be sent periodically, depending on the configuration: 

• monthly (selectable day of the month and hour), 

• weekly (selectable day of the week and hour), 

• daily (selectable hour). 

To enable automatic sending of reports in the program, check the box ‘Turn on periodic report 

sending’. The user must fill in the following fields: 

• e-mail addresses to which reports will be sent (multiple addresses must be separated by 

commas), 

• address and port of the outgoing mail server (SMTP), 

• select whether the connection will use SSL encryption, 

• e-mail account address and password, 

• cycle, date and time of sending reports. 

After configuration, click on ‘Test message’. After the correct configuration of the mailbox, the 

user will receive information that the test message was sent to the addresses provided. 

NOTE! Automatic generation and sending of reports is possible only when ELVIS is enabled at 

a specified time. 
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15. ELVIS Online 
 

 

If the ELVIS Online module was installed together with the main application, the user can view 

the system status on all devices connected to the same local network as the computer on which 

the ELVIS application is installed. After typing the computer’s IP address in the browser as 

address:8080, a website containing a list of central stations added to ELVIS will appear. Each 

central station shows information about the connected C-Bridge distributors. Click on the 

channel or number of fittings to go to a website containing information about fittings.  

NOTE! The website is available only when ELVIS is enabled at a specified time. 

16. Closing Remarks 
• After entering login details to one of the central stations, these details will be used when 

trying to connect with other central stations. 

• Only one ELVIS can be connected with one central station at the same time. 

• When using ELVIS, it is recommended not to be logged in to central stations installed on 

the monitored building. 

• The program should be made available only to authorised persons. 
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17. System requirements 

Minimal system requirements: 

• MS Windows 7, Windows 8 or Windows 10, 

• Intel Core i5  processor or similar, 

• 4GB RAM, 

• 5 GB disk space, 

• Graphic card Nvidia GeForce 7000 series with 512MB or similar, 

• Main monitor with screen resolution 1280x1024. 

 

Recommended system requirements: 

• MS Windows 7, Windows 8 or Windows 10, 

• Intel Core i7 processor or similar, 

• 8 GB RAM, 

• 10 GB disk space, 

• Graphic card Nvidia GeForce 8000 series with 1024 MB or similar, 

• Main monitor with screen resolution 1600x1200. 
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TM TECHNOLOGIE Sp. z o.o. 

32-084 Morawica 

355, near Krakow 

 

tel.: +48 12 444 60 60 

fax: +48 12 350 57 34 

www.tmtechnologie.pl 


